Trying to use Maltego-CE for my graphs...

Discussion in 'Previous builds' started by Seshemw, Feb 14, 2017.

  1. Seshemw

    Seshemw Active Agent

    I fetched the Windows X64+Java MaltegoCE that Anashel posted the link to.
    Installer ran.
    Configuration tool seems to run.
    Java x64 1.8.0_121 is installed (as is Java 32 bit 8 121, though that shouldn't matter).

    When I try to launch the Maltego app (or click on associated files like the NT4 transform), it doesn't really run.
    When I run it from a cmd, I get
    The launcher has determined that the parent process has a console and will reuse it for its own console output. Closing the console will result in termination of the running program.
    Use '--console suppress' to suppress console output.
    Use '--console new' to create a separate console window.
    Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=128m; support was removed in 8.0
    A popup box from Java(TM) Platform SE binary shows up:
    Java(TM) Platform SE binary has stopped working​
    I tried changing the etc/montego.conf file to remove mention of the like that HotSpot seems to not like, with zero changes (so I put it back the way it started).
    I've given it memory ranging from 4096M to 8192M to 12+G in the configuration tool with no changes.
    The logs (in users\<user>\AppData\Roaming\.maltego\v4.0.11CE\var\log) are empty. They make a new log file every time I try to execute, but the log file remains empty.

    Went into the windows event files, and got more info... but it appears to be video driver related?!
    Faulting application name: java.exe, version: 8.0.1210.13, time stamp: 0x584f5d7e
    Faulting module name: nvSCPAPI64.dll, version:, time stamp: 0x588218a5
    Exception code: 0xc0000409
    Fault offset: 0x0000000000034b2f
    Faulting process id: 0x2358
    Faulting application start time: 0x01d286fcf3dc531e
    Faulting application path: C:\Program Files\Java\jre1.8.0_121\bin\java.exe
    Faulting module path: C:\Program Files (x86)\NVIDIA Corporation\3D Vision\nvSCPAPI64.dll
    Report Id: a56602f9-75c1-4c88-a4ba-7da02c4d149a
    Faulting package full name:
    Faulting package-relative application ID:
    I have a dual monitor setup, and my main monitor is an unusual resolution and ratio, but yeesh. 2560x1600 shouldn't be fatal for a java app.
    Dropped it to 1920x1080, no change. Tried running it from the other monitor, no change. Removed my second monitor, no change.

    Edit: Self-answered. Since the Nvidia 3D seemed to be having some bad interaction with java64, I removed it with a clean install of a fresh nvidia driver set (leaving off all unused things, only keeping video driver and physx, removing HD audio, 3d controller, 3d display, etc).
    MaltegoCE now runs.
    Last edited: Feb 14, 2017
    Balamung likes this.
  2. gentianbrija2010

    gentianbrija2010 Active Agent

    What is this.
  3. Kakuzen

    Kakuzen Gold Member

    Nvidia drivers causing issues once again. Why am I not surprised lol (GTX 1070 guy here)
  4. deadbeatsaint

    deadbeatsaint Active Agent

    Perhaps that's the freezing issue I'm having with the program. It actually runs great for a while, but when doing innocuous activities (such as creating a New Entity Type) the program not only hard freezes, even after I kill it from task manager (and I mean utterly) it somehow sticks around (or appears to above the desktop level). Bizarre behavior. :oops:

Share This Page