Credentials Lost after JanuaryUpdate

Discussion in 'Technical Support' started by archdruidardanos, Feb 16, 2019.

  1. archdruidardanos

    archdruidardanos Active Agent

    Hi there,

    it seems the latest update messedup the credentials for the game.

    - no login possible
    - credentials recovey tool not working

    Tried to reach out via.

    - mail to support -> any delivered mail will just be bounced
    - tried to reach via PM to one of the staff person -> forum bounces message while pointing out it may be spam...

    Could test the way via discord - due to lacking the info of discord server…

    Any option how to get back into game without starting over again and losing 30 hours of process….

  2. AgentZeus

    AgentZeus Senior Agent

  3. archdruidardanos

    archdruidardanos Active Agent

    thanks i will give it a try with the discord part :D. thanks for the link
  4. Kageoni

    Kageoni Active Agent

    Well all I got was you can reach support x way when i asked about the issue on discord.

Share This Page