Alpha 1.1.1 - Pc And Mac Edition

Discussion in 'General' started by Anashel, Nov 22, 2014.

  1. Anashel

    Anashel Puppet Master Staff Member

    Hi fellows Members!

    If you are up for it, it's time to test out some stuff for us! We have a shiny new Alpha version out. Pleas keep in mind this is just an alpha and take the time to read the bug list at the end of the post.

    1. Download the PC Version >>> here
    2. Download the MAC Version >>> here
    3. Unzip the file on your desktop or any location you want
    4. Depending on your OS versions, the first time you executed the game you may be ask permission to run it.
    5. To exit the game, just hit ESC and click 'QUIT'


    You can read the initial post on Alpha 1.1.0 here.

    Change log
    • Our main goal was to solved the Memory Leak issue. We rebuilt the TV hub from scratch
    • Skinning for the browser, tab will be introduce later
    • Map now show number of agents at the same location
    • Agents location on the map has been fixed
    • Lots of small optimization improving the framerate from 15 - 20 fps to 200 fps
    • Lots of bug fixing in the backend (how data was saved, etc...)


    • On the register screen, two password check don't give an error if they are not the same.
    • Some window ratio leave a blank line in the UI on both edge of the screen.
    • All agent are set to Cyber-tech with a generic icon instead of the forums thumbnails.
    • Map is still slow under 1920 x 1200 resolution. It is much faster under 1680 x 1050 resolutions and less

    • Dragging the window during the intro logo video causes it to stutter.
    • [Dual-Monitor] Left/right screen select always chooses smack dab in the middle across both
    • No confirmation email when registering.
    • Client takes into account pre-existing PlayFab accounts. (See below for possible workaround)
    • Client accounts are seperate from Forum accounts (you need to make a new one, or both if you are just joining)
    • [Fixed] Tabbing between fields on registration/login screen does nothing (the goggles!), nor does Shift-Tab.
    • Username is forced lower-case; e-mail is not.
    • Changes to In-game settings (Music & Sound Effects) revert back to 'on' when you relog, if you disable them.
    • [Fixed] Tapping ESC twice freezes the controls.
    Situation Room:
    • On the Situation Room screen, resizing the window vertically will scale the room/TV content, but resizing horizontally will only letterbox or cut it off
    • Geolocation only occurs on registration.
    • [Fixed] Browser lacks some identifying markers; writing cursor, mouser-over cursor change, etc.
    • Some keyboard shortcuts do nothing (goggles!); end/home does not move the writing cursor, for example.


    Pre-existing PlayFab Account:
    1. If you've played "Loadout" or "Planetary Annihilation", edit those accounts so they no longer make use of the email you want to use for TBW.
      You can then create your TBW account, and revert the other accounts back to the original email.

    2. After registration, your account should be accessible via PlayFab using this link.
      Note: there are two login prompts; the above for "players", and another for the companies using PlayFab - keep an eye on the URL extension. If it says "developer.playfab", you're at the wrong login - it should read "portal.playfab".
      1. To log in to your account, you need to add "tbw" before your username. E.g. if your username is "scruffy", you need to use "tbwscruffy" to log in.

    Slow map:
    1. Try to run the game at "Fantastic" settings.
      • Note that running the client on "Fastest" will have the opposite effect; it allocates less resources to the Map, so it will perform worse than if set to "Fantastic"
    Last edited by a moderator: Nov 30, 2014
  2. nikel

    nikel Lab 1852 - Neurals

    The browser is working much more smoothly than before, definitely an improvement here. Only thing I've noticed so far is that on the settings "Display Name" is set to "Agent Display Name" for me when hitting escape. I'll update as I find more bugs.

    As far as more usability, browser and map still are not compatible with my two finger touchpad scroll, I've noticed, and doubleclicking to select all text in a line does not work (mostly a problem when trying to clear a long google url to put something new in.)
    2 people like this.
  3. Santiak

    Santiak MIA

    Nice addition of the Agent counter on the Map Screen markers. ^^

    Will test some of the previously reported bugs if possible, and of course, add new ones:

    • [Unable to reproduce reliably at the moment, somewhat rare] Writing in the address bar of the Browser may sometimes also write in any highlighted input box on the website (i.e. Google search)

    • If you leave a room before it's done loading, the game is likely to freeze. In this state, music still plays, but buttons cease to function, and you can not leave the room (much like the previous "double ESC" bug). However, both the button and room itself will "blink" when pressed. This happens most often when:
      • Leaving a room before it has fully faded in (freezes on attempt).
      • Sometimes when leaving Browser while a page is loading/while writing the URL (freezes after attempt, or upon re-entering browser)
        • Note: This does not seem to be a memory leak. Have left the client hanging in this state while writing this section, and so far the client has only used ~172k KB, not rising, client not completely frozen either.
    • Both the Situation Room and Map load substantially slower than before for me.

    • If playing with Music and Sound Effects muted, the sound briefly turns back on when switching rooms.

    • One of the monitors (#19) timed out just now (22nd of November ~06:40 pm EST, 23rd of November 00:40 am CET). Attempted changing rooms and back as well as relogging, but the issue persists.
    Last edited by a moderator: Nov 22, 2014
  4. Bink

    Bink Senior Agent

    I'm on the mac version. it allowed me to register within the app but i cannot log into playfab and there doesn't seem to be a way to register on playfab without being a dev. also i never received a confirmation e-mail. i can go to the different screens and the browser is nice. the map however doesn't work (it's all stretched diagonally or something).

    Also, I think I messed up where I'm Bink here on the forums yet I registered as Binku. There doesn't seem to be a way to change it. Does this matter when it comes to linking both the forum and game, or does it just go by the email registered?
    Last edited by a moderator: Nov 22, 2014
  5. kelbris

    kelbris Senior Agent

    Everything works fine for me, aside from the playfab but that is being worked on. I find it funny that I am the ONLY player in Australia at the moment. :(
  6. rand();

    rand(); Active Agent

    For now this version is working pretty well, the memory leak is indeed fixed. Same issue that Nikel with the touchpad and the "Display Name" field. About Santiak:
    The opposite is also likely to happen, the only way to reproduce this event is to select the address bar then typing something to see if the text is appearing in the input box, if not: do the same thing with the input box and then resume the whole process until it works, it is rare but not that much.
    I'd like to add that i cannot go directly to the mission room from the browser (the button itself is working normaly but the link just seems to not be there).
    Last edited by a moderator: Nov 22, 2014
  7. rand();

    rand(); Active Agent

    @Deepthroat :
    That's why your location is locked. (except if you used your VPN when registering a new account)
    2 people like this.
  8. MochiInvasion

    MochiInvasion Senior Agent

    it started pretty slowly for me, loads really quickly once it's open tho and doesn't 'hang'. i tried changing a setting and it says it crashed, but responded again pretty quickly?? (this only happened once tho). map loads a bit quicker but it still moves really slowly* for me, tho changing between screens is much quicker.

    *not sure how much of this is game and how much is my computer
  9. Anashel

    Anashel Puppet Master Staff Member

    Can you send me your crash log please Mochinvasion?
  10. Erebe

    Erebe Senior Agent

    Toujours le problème de Pentecôte la carte et le navigateur ^^
  11. TheChosenOne

    TheChosenOne Active Agent

    Did some quick testing.
    - Video screens now "pop in" but there is no more lag in that screen.
    - Browser remember stuff I do, shiny.
    - Map has been impoved. Still a bit slow, but like the thing with the numbers.
    - No new bugs so far.
    2 people like this.
  12. Deepthroat

    Deepthroat Guest

    My bad, I missed that part. Thanks.
    2 people like this.
  13. Ashielf

    Ashielf Senior Agent

    I'm from Switzerland. So it seems my country doesn't like it, too. :-\

    Notes to 1.1.1:
    • The situation room takes a little bit longer to start (videos popping up) than before; but it is still in a bearable timeframe (7 seconds upon entering the view).
    • Map is still empty for me, see attached image.
  14. Bink

    Bink Senior Agent

    Also, don't tell Gwen but there is a striking resemblance to her and the hooded figure that killed capt William patrick... Just sayin... That woman's got some anger issues lol
    4 people like this.
  15. MochiInvasion

    MochiInvasion Senior Agent

    i don't know if crash is the right word here - when i tried to change one of the settings i got a 'this is not responding' message and the blue spinny wheel of death, alt-tabbed away and back again and it was working again. sorry if this is a silly thing vov
  16. Erebe

    Erebe Senior Agent

    je pense ashielf et me have a different problem. He see the map but not the cursor... i have just a black screen ...
  17. Kle

    Kle Senior Agent

    Ohh, I got in.... But then I got a C++ Runtime error popup when switching to the map (I'm not amazingly technical so I have no idea what that means :p)

    Edit: Switching to anything other then the Situation Room proper, Mission Screen and settings brings up the C++ Runtime error.

Share This Page