Alpha 0.8 Bugs

Discussion in 'Previous builds' started by DanDG, Jul 15, 2017.

  1. DanDG

    DanDG New Agent

    "We believe their news report have been compromise"
    Needs grammar redoing if no one pointed it out
    Also in xkeyscore forensics, Insurance is spelt as "Insurence"
  2. LogThatData

    LogThatData Moderator

    I think the Anashel hivemind is bugged now, I tried every possible phone in the airodump and none of them worked
  3. MattGD

    MattGD Active Agent

    Anashel likes this.
  4. Anashel

    Anashel Puppet Master Staff Member

    Bug report from BlueOrbit:

    Each time you "dig" the employee registrar, you are able to increase Laura's personal and professional percentages in XKEYSCORE. This appears to be stackable with no limit

    After adding the News Stream Live icon the XKEYSCORE and removing/moving it around, it appears to get stuck in the middle of the screen (I don't have any more details of the exact way this happened I'm afraid).

    There is a spelling error in XKEYSCORE where "The current query do not have enough specific..." should read "The current query does not have enough specific..."

    By filling all 3 XKEYSCORE slots, then removing slot 2 followed by slot 3, both 2 and 3 will appear as optional entities.
  5. baktic

    baktic Active Agent

    In the description for the mission "Private Communications" Chief Officer calls the Turbine C2 Registry, the Turbine C3 Registry.
  6. codex-13

    codex-13 Senior Agent

    The foxacid module doesn't show a cursor where you can enter information most of the time, so I didn't realize that you could type in those boxes.
  7. Seshemw

    Seshemw Active Agent

    Mission A-03 (Blocked Off), appears to have a bug in mission objective advancement.
    Bug appears to be related to new "fingerprint" tool behavior.

    Spoiler contains complete answers to help scope the possible bug. Please do not read if you don't want the specifics.
    Mission objectives were model of IP Web camera, and port number and technology used for SSH services.
    Ran fingerprint against each IP.
    fingerprint shows the camera (first objective should be complete?)
    Ran osintscan against all IPs to find domain name.
    Ran sfuzzer against domain name to find exploitable server hostname
    fingerprint reveals technology that should be their SSH service, and port number.
    Screenshot has both scans, performed after exploiting the vulnerable service and connecting to the server. Both of these scans were also run with the vpn disconnected, just in case.

    Several users in Discord reported the same thing, so I cleared my mission progress completely, and worked back up to it. Mission does not appear to advance (though
    I can go on to explore other hosts and services found, which are things I remember being in mission A-04
    Agent Seshemw
  8. Seshemw

    Seshemw Active Agent

    Still seeing a bug from when Hivemind went in for file trades. Specific intel packages don't show checks in the trade (when you have them). Or don't transfer to you when the trade is 'successful'.
    Example, using Forgotten.
    connect to forgotten.hvm
    Click the trading tab
    Top entry is "Player: Password Dictionary for Medical Professionals Server: Alpha Centauri IRM Response Soundfile"

    I have the password dictionary, it has a check.
    The Alpha Centauri has no checkmark. I click the alphacent file. T
    ext on the right ends with "To make this transaction, type this command: trade 396".
    I type "trade 396".
    It tells me the trade was successful, new intel available in XKEYSCORE.
    The server node box for the file still has no check. I exit the HVM node. I reconnect. It still has no check. I exit the HVM. I check Agent Profile, inventory, I see the file (One silver chevron, Alpha Centauri IRM Response Soundfile).
    I have also tried fully exiting the application, coming back in, and reconnecting to forgotten.hvm. Still shows as not owned.
    In previous versions of the bug, you would often not get the item in your agent inventory. I'm trying to see which specific files are still like that, but resetting my progress also reset my HVMs, so I'm rebuilding that now.
  9. Seshemw

    Seshemw Active Agent

    If you have a tool window open in the workspace (for example, fingerprint window), you can still issue commands in cli that spawn a new window with text elements filled in (specifically foxacid). Please don't fix this one. it gets around the really irritating 'will not tab complete, but obscures notepad' behavior of the next foxacid.
    "foxacid <target FQDN> -p <port> -t <technology>" will spawn foxacid's window, with the three text boxes for FQDN, technology, and port pre-filled in. Which is a good thing, IMO.
    I seem to be unable to get the help for that syntax anymore, but still remembered it.
  10. TheNorseMan

    TheNorseMan Active Agent

    The anashel hivemind is working; I cracked it last night.
    Last edited: Jul 18, 2017
    LogThatData likes this.
  11. Seshemw

    Seshemw Active Agent

    mss.hvm requires a slightly different methodology than many. It is working in A.8 (or at least, I just finished it after resetting for .8)
    use osintscan instead of sfuzzer from the outside, and you can find things. May depend on -s selection.
  12. zaelong

    zaelong Moderator

    MSS.hvm works fine, you just need to use the right source
    SanctuaryOfSecrets.hvm is still broken; even after locating the phone, the launcher doesnt recognise it. (there is a workaround to still get into it though)

    the new hivemind Resistance.hvm has the same issue as SanctuaryOfSecrets, and i noticed that there might be a typo in his username; the username is SteveGao, whil his last name is Goa
    Last edited: Jul 27, 2017
  13. TheNorseMan

    TheNorseMan Active Agent

    yup just figured that out. sometimes hard to tell what is a bug and what is simply a different type of puzzle.
  14. TheNorseMan

    TheNorseMan Active Agent

    I've been unable to get
    arkaham asylum soap notes or alpha centauri IRM response
    trades to work so far.
  15. Silox

    Silox Active Agent

    A couple of spelling and grammar mistakes

    "when the Document Conversions Load Balancer Service is enabled, allows" should be "when the Document Conversions Load Balancer Service is enabled, it allows"


    Should be "Media & Advertising"
  16. TheNorseMan

    TheNorseMan Active Agent

    adding to the list of typos: tab completes as
  17. KaoSway

    KaoSway Active Agent

    More typos:
    TheNorseMan likes this.
  18. zaelong

    zaelong Moderator

    i found a bug when using the foxacid command (rather then launching the module)
    when you launch foxacid the old way (by typing "foxacid [target] -p [port] -t [tech]), when using a tech that includes a '-', then everything after the '-' will be included after the target, instead of in the technology box.
  19. lolzor

    lolzor New Agent

    A couple things:

    - Lowering Voice volume also lowers the briefing volumes, and after muting voice; raising it again has no effect. So now i can't hear briefings. I just didin't want to hear "INFORMATION GATHERING MODULE, INITIATED" everytime i pressed enter...

    - I noticed when opening FOXACID that sometimes when a window opens with it's top bar beyond the screen's upper border; there's no way to move or close it. I tried alt-f4 and, well, you can imagine how that went. Maybe some kind of taskbar where you can right-click to close, minimize or maximize windows would be good to have.

    Mission 01:
    On mission 01 - News Leak; fingerprinting all 4 subdomains will not complete the mission. I had completed News Stream Live as well as hacked 4 HVM nodes before getting into those missions. Also before scanning all 4 subdomains, i immediately broke into filehost and netscanned it; thinking that was the goal. Maybe some sequence of actions i did broke it. Had to use skeleton to skip the mission.

    Mission 03:
    Despite being connected to; password attack gives me "No active host/proxy" error on and every variation of that.
    Last edited: Jul 25, 2017
  20. lolzor

    lolzor New Agent

    Also nooot sure if it's a bug but with HVM's...
    When hacking HVM's i noticed many had the same person; so i figured the passwords should be the same. So i tried entering the hvm command as entered after a successful password attack "hvm example.hvm -u bla -p bla"; yet it never connects me, despite confirming after that it is indeed the same username and password as the other node, hence the command should logically have worked. Might just be a game thing, but you know :p

Share This Page